EL8 packages repository

Тема для обсуждения репозитория пакетов pkgs.sysadmins.ws
Ответить
Аватара пользователя
Raven
Бородатый сис
Бородатый сис
Сообщения: 2795
Зарегистрирован: 03 мар 2010, 15:12
ОС: RHEL 8
Откуда: Из серверной

EL8 packages repository

Сообщение Raven » 16 июн 2021, 12:30

Warning:
  • The packages in these repo were not tested for compatibility with CentOS Stream.
  • Never perform a dnf update with extras repository turned on - there is a risk of damaging the system


Repository contents:
  • base - packages not present in the base system
  • extras - packages upgrading or conflicting with the native packages of the distribution
  • modular - modular repository with packages that are not allowed to be installed on a non-modular basis (httpd, nginx)
  • multimedia - packages with all sorts of audio/video players and related libraries, codecs
  • testing - packages which haven't been tested yet
Also available at the moment:
  • Krita graphical editor
  • rar and ark with rar support
  • Falcon and Otter browsers
  • yakuake pop up terminal
  • birdtray - wrapper for thunderbird that allows to hide it in a tray
  • clementine, deadbeef, mplayer (with mencoder), vlc, strawberry, ffmpeg, avidemux, kdenlive
  • wine is updated to 7.x, also compiled for x86 architecture, because many windows applications doesn't run under x86_64
  • latest versions of mc, nano, varnish
  • sauerbraten
  • dovecot is updated to 2.3
  • exim latest version, built with DMARC, SRS, ARC support
  • httpd compiled with cPanel patch, which allows to use common fcgid wrapper for suexec
  • nginx-cp - is a customized build of the stable nginx branch, built with geoip2, lua, brotli, headers_more modules, and includes cloudflare patches
  • python310-* - a Python 3.10 built with a base set of modules
  • qemu-6.1.0 (there is a conflicting dependency, use with care!!!!)
  • pipewire-0.3.40 can be used as a drop-in replacement for the JACK and Pulseaudio
  • qbittorrent a bit-torrent client suppoting BitTorrent V2
  • gtk4, qt6 and qt4
  • kernel-rx - a latest Linux LTS kernel, built with some additional features such as Reiserfs, OCFS2 and Android Binder IPC
  • kernel-rxl - the same as kernel-rx, but based on the legacy LTS branch
Graphical environments:
  • LxQt
  • LXDE
  • Pantheon
  • I3
  • XFCE 4.16 - removed due to epel version upgrade
  • some of KDE parts, missing or poorly built in epel
To use these repos you need to install the raven-release package

Код: Выделить всё

# dnf localinstall https://pkgs.dyn.su/el8/base/x86_64/raven-release-1.0-2.el8.noarch.rpm
The extras repository is disabled by default to avoid conflicts and you should enable them if needed, i.e. to install wine you have to run following command:

Код: Выделить всё

dnf --enablerepo=raven-extras install wine.i686 wine-core.i686 wine-pulseaudio.i686 wine-capi.i686 wine-cms.i686 wine-ldap.i686 wine-openal.i686 wine-core wine-pulseaudio wine-capi wine-cms wine-ldap wine-openal
* Wine may also need mesa-dri-drivers for both architectures
Я не злопамятный, я просто часто ковыряю логи
Ответить

Вернуться в «Репозиторий»