CentOS 7- Из-за шлюза тупит Samba, Ssh

Операционки на базе Unix
Ответить
Аватара пользователя
BinuraL
Юзер
Юзер
Сообщения: 66
Зарегистрирован: 11 июн 2014, 14:50
ОС: CentOS
Контактная информация:

CentOS 7- Из-за шлюза тупит Samba, Ssh

Сообщение BinuraL » 26 авг 2014, 14:50

День добрый.
Работает сервер на CentOS 7, 2 сетевые, Первая смотрит в инет, другая в локалку. Все как бы ничего но когда пропадает инет перестают работать Самба и Ссш тупит...
Подскажете в чем может быть причина при отсутствии шлюза сервер стает неработоспособным... На сервере работает ISCSI и через самбу запускает plink и дальше запускает на сервере скрипты....
Аватара пользователя
Raven
Бородатый сис
Бородатый сис
Сообщения: 2787
Зарегистрирован: 03 мар 2010, 15:12
ОС: RHEL 7
Откуда: Из серверной

Re: CentOS 7- Из-за шлюза тупит Samba, Ssh

Сообщение Raven » 28 авг 2014, 15:38

Для начала я бы курнул настройки firewalld - какая-то новая надстройка над iptables, суть которой я до сих пор так и не понял. Вроде как должна работать динамически, так вот может оно динамически блочит и внутренний интерфейс?
Я не злопамятный, я просто часто ковыряю логи
Изображение
Аватара пользователя
BinuraL
Юзер
Юзер
Сообщения: 66
Зарегистрирован: 11 июн 2014, 14:50
ОС: CentOS
Контактная информация:

Re: CentOS 7- Из-за шлюза тупит Samba, Ssh

Сообщение BinuraL » 28 авг 2014, 16:26

Firewalld отключен, SELINUX тоже отключен, странно одно что при отсутствии шлюза (например на некоторое время 1-2мин) начинает тупить самба нету доступа и ссш ужасно тупит, трафик локальный ходит на том же ISCSI, может быть возможно что это связано с ДНС?
Аватара пользователя
Raven
Бородатый сис
Бородатый сис
Сообщения: 2787
Зарегистрирован: 03 мар 2010, 15:12
ОС: RHEL 7
Откуда: Из серверной

Re: CentOS 7- Из-за шлюза тупит Samba, Ssh

Сообщение Raven » 28 авг 2014, 17:34

Вполне возможно.
Я не злопамятный, я просто часто ковыряю логи
Изображение
Аватара пользователя
BinuraL
Юзер
Юзер
Сообщения: 66
Зарегистрирован: 11 июн 2014, 14:50
ОС: CentOS
Контактная информация:

Re: CentOS 7- Из-за шлюза тупит Samba, Ssh

Сообщение BinuraL » 26 окт 2014, 04:00

Причина была в avahi-daemon.service из за него тупило(а) Самба и SSH. Отключив этот сервис все стало на свои места *YEAH*
Аватара пользователя
BinuraL
Юзер
Юзер
Сообщения: 66
Зарегистрирован: 11 июн 2014, 14:50
ОС: CentOS
Контактная информация:

Re: CentOS 7- Из-за шлюза тупит Samba, SSH

Сообщение BinuraL » 26 окт 2014, 12:52

После отключения Avahi Самба перестала тупить при отсутствии шлюза (интернета), но ssh все же подтупливал немного полазив по интернету нашел решения для ssh.
Было: отключены, добавлены, такие параметры:

Код: Выделить всё

UseDNS no
и

Код: Выделить всё

UsePAM no
Но все же подтупливало..
поставив значение no в # GSSAPI options

Код: Выделить всё

GSSAPIAuthentication no
После этих манипуляций ssh начал отлично реагировать без шлюза...
Аватара пользователя
Infernal Flame
Злой Модер
Сообщения: 1795
Зарегистрирован: 03 мар 2010, 11:25
ОС: Centos 7
Контактная информация:

Re: CentOS 7- Из-за шлюза тупит Samba, Ssh

Сообщение Infernal Flame » 26 окт 2014, 23:19

BinuraL
браво! полезная информация для многих.
Изображение
Изображение
Work: Centos 7 х 'all Servers'
Ответить

Вернуться в «Unix»